Donnerstag, 7. Mai 2009

HOWTO: Stable Xephyr on Ubuntu 9.04 for Fremantle SDK

As stated in the Fremantle SDK Installation Notes, Xephyr on Ubuntu 9.04 crashes when clicking on a text field in the Fremantle Beta SDK. It also says that the Intrepid (Ubuntu 8.10) version works better. Here is how you can compile and install Intrepid's Xephyr version:

sudo apt-get build-dep xserver-xephyr
sudo apt-get install build-essential devscripts
dget http://at.archive.ubuntu.com/ubuntu/pool/main/x/xorg-server/xorg-server_1.5.2-2ubuntu3.dsc
dpkg-source -x xorg-server_1.5.2-2ubuntu3.dsc
cd xorg-server-1.5.2/
debuild
cd ..
sudo dpkg -i xserver-xephyr_1.5.2-2ubuntu3_i386.deb
Xephyr :2 -host-cursor -screen 800x480x16 -dpi 96 -ac &

Now you can start the Fremantle Beta SDK and run it without crashing all the time :) You can delete the rest of the .deb packages created - they are not needed for Xephyr. If you want to go back (well... "forward" really) to Jaunty's Xephyr package, you can simply use sudo aptitude install xserver-xephyr to upgrade it.

Kommentare:

thopiekar hat gesagt…

thanks!

renato_el_matador hat gesagt…

Thanks, this process takes a lot of time but it works!

Andrea Grandi hat gesagt…

You can try this too: http://www.murrayc.com/blog/permalink/2009/06/09/xephyr-on-ubuntu-jaunty/

Shalin Mehta hat gesagt…

Hello, I have tried to follow steps as shown above and I am getting error in this step: dget http://at.archive.ubuntu.com/ubuntu/pool/main/x/xorg-server/xorg-server_1.5.2-2ubuntu3.dsc

it's showing error like
dscverify: xorg-server_1.5.2-2ubuntu3.dsc failed signature check:
gpg: Signature made Thu 23 Oct 2008 07:43:54 AM PDT using DSA key ID E0E67611
gpg: Can't check signature: public key not found
Validation FAILED!!


How can I solve it?

thp hat gesagt…

Shalin: The signature check is not really needed (so the message you get is not an error, but just a warning). If you want to check the signature, use apt-key, see http://wiki.debian.org/SecureApt (especially the section "How to find a key").